Update
We are continuing to monitor for any further issues.
Posted Oct 30, 2025 - 08:48 EDT
Monitoring
We are seeing improvements in impact to Blackbaud solutions/services caused by an outage with Microsoft Azure, including successful log in attempts using Blackbaud ID. We will continue to evaluate and monitor our solutions overnight. We will update again tomorrow at 10 a.m. ET. Please continue to follow this page for additional updates.
Posted Oct 29, 2025 - 19:10 EDT
Update
Multiple Blackbaud solutions continue to see varying levels of degradation due to a reported outage with Microsoft Azure. NCSSM is seeing significant impacts to Blackbaud ID users who may experience issues when trying to access Blackbaud solutions or Customer Support online. While we do not have a restoration timeline on the outage from Microsoft, Blackbaud and NCSSM ITS will continue to work internally to resolve the impact to our customers as quickly as possible. Please continue to monitor this page for further updates.
Posted Oct 29, 2025 - 15:17 EDT
Update
At this time, Raiser's Edge, Financial Edge, and Blackbaud's Student Information System are down.
Like many organizations, Blackbaud solutions are currently impacted by an outage with Microsoft Azure. NCSSM is actively investigating and working to mitigate impact to our customers. This issue may prevent users from signing in with Blackbaud ID or using Blackbaud solutions and may also impact contacting Blackbaud Customer Support online. Blackbaud is working to diagnose and resolve the issue as quickly as possible. Please continue to check this page for updates.
Posted Oct 29, 2025 - 12:30 EDT
Investigating
We are currently investigating this issue.
Posted Oct 29, 2025 - 12:28 EDT
This incident affects: Zoom (Zoom Zoom Meetings, Zoom Zoom Video Webinars), Dialpad (Dialpad Telephony Infrastructure: Inbound Calls, Dialpad Telephony Infrastructure: Outbound Calls, Dialpad Texting Infrastructure, Dialpad Website), Blackbaud (Blackbaud Financial Edge (and NXT), Blackbaud Raiser's Edge (and NXT), Blackbaud SIS), Network (Durham Campus Network, Morganton Campus Network), NCID and BEACON / FIORI (NCID, BEACON / FIORI), 1Password (1Password Sign in, 1Password Sign up, 1Password Syncing items between your devices, 1Password Saving password and other items, 1Password Access to passwords and other items), Shopify (Shopify Checkout, Shopify Point of Sale, Shopify Admin, Shopify Reports and Dashboards, Shopify Support), and Canvas LMS, Microsoft Office and OneNote, Website, SchooLinks.