Google Sites access issues in Durham
Incident Report for ITS
Resolved
We identified that the issue was that Google blacklisted our public IP address. The request was made to be removed from the blacklist and it was granted.
Posted Oct 17, 2024 - 09:19 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 16, 2024 - 13:01 EDT
This incident affected: Google (Google Apps Sites).