Students and Staff Cannot Access Google Sites
Incident Report for ITS
Resolved
This incident has been resolved.
Posted Oct 17, 2024 - 16:12 EDT
Identified
We have heard that some people are still having trouble accessing Google Sites on-campus. We are working on implementing a solution.
Posted Oct 17, 2024 - 11:19 EDT
This incident affected: Google (Google Apps Sites).